summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGwenole Beauchesne <gbeauchesne@splitted-desktop.com>2009-07-08 07:54:44 +0000
committerAustin Yuan <shengquan.yuan@intel.com>2009-08-28 11:00:00 +0800
commite2a24f0189561cc4feaf00d0b48f22947704ae56 (patch)
tree0e398b0c611b7dfc19bd0fe7bd3a47099e3f6dfd /configure.ac
parent4e71a2ddfd56543c60e91525726d136a526d1162 (diff)
downloadlibva-e2a24f0189561cc4feaf00d0b48f22947704ae56.tar.gz
Split libva DSO into core (libva.so) and display-dependent parts (libva-x11.so).
Signed-off-by: Austin Yuan <shengquan.yuan@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c1ffc0a..b37a438 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,8 +114,12 @@ AC_SUBST(LIBVA_LIBS)
pkgconfigdir=${libdir}/pkgconfig
AC_SUBST(pkgconfigdir)
-libvabackendlib=libva.la
+LIBVA_DISPLAY=x11
+libvacorelib=libva.la
+libvabackendlib=libva-$LIBVA_DISPLAY.la
+AC_SUBST([libvacorelib])
AC_SUBST([libvabackendlib])
+AC_SUBST(LIBVA_DISPLAY)
AC_OUTPUT([
Makefile
@@ -130,5 +134,6 @@ AC_OUTPUT([
i965_drv_video/shaders/render/Makefile
test/Makefile
libva.pc
+ libva_display.pc
])