summaryrefslogtreecommitdiff
path: root/va/x11/Makefile.am
diff options
context:
space:
mode:
authorAustin Yuan <shengquan.yuan@gmail.com>2010-03-24 10:43:53 +0800
committerAustin Yuan <shengquan.yuan@gmail.com>2010-03-24 10:43:53 +0800
commit92e17d62fd6a9249906e284a28926010dc2c1639 (patch)
treed49e829d721dfe95bd71e446fc7ff93db6c2ccaf /va/x11/Makefile.am
parent5405c6ed5838af9294a17acc2140bffb2d282beb (diff)
parent11f69c8407d2d1ee68d9ca12f650a62a3b0bef64 (diff)
downloadlibva-92e17d62fd6a9249906e284a28926010dc2c1639.tar.gz
Merge branch 'master' of git+ssh://AustinYuan@git.freedesktop.org/git/libva into sync-fdo-master20100324_5.3.0.0000
Diffstat (limited to 'va/x11/Makefile.am')
-rw-r--r--va/x11/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/va/x11/Makefile.am b/va/x11/Makefile.am
new file mode 100644
index 0000000..40346f1
--- /dev/null
+++ b/va/x11/Makefile.am
@@ -0,0 +1,30 @@
+# INTEL CONFIDENTIAL
+# Copyright 2007 Intel Corporation. All Rights Reserved.
+#
+# The source code contained or described herein and all documents related to
+# the source code ("Material") are owned by Intel Corporation or its suppliers
+# or licensors. Title to the Material remains with Intel Corporation or its
+# suppliers and licensors. The Material may contain trade secrets and
+# proprietary and confidential information of Intel Corporation and its
+# suppliers and licensors, and is protected by worldwide copyright and trade
+# secret laws and treaty provisions. No part of the Material may be used,
+# copied, reproduced, modified, published, uploaded, posted, transmitted,
+# distributed, or disclosed in any way without Intel's prior express written
+# permission.
+#
+# No license under any patent, copyright, trade secret or other intellectual
+# property right is granted to or conferred upon you by disclosure or delivery
+# of the Materials, either expressly, by implication, inducement, estoppel or
+# otherwise. Any license under such intellectual property rights must be
+# express and approved by Intel in writing.
+
+AM_CFLAGS = -DLINUX -I$(top_srcdir)/va $(DRM_CFLAGS)
+
+noinst_LTLIBRARIES = libva_x11.la
+
+libva_x11includedir = ${includedir}/va
+libva_x11include_HEADERS = va_dri.h va_dri2.h va_dricommon.h
+
+libva_x11_la_SOURCES = va_x11.c va_dri.c va_dri2.c va_dricommon.c dri2_util.c dri1_util.c va_nvctrl.c
+
+EXTRA_DIST = va_dristr.h va_dri2str.h va_dri2tokens.h va_nvctrl.h