summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b6a84de..331394b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,4 +22,24 @@
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = va dummy_drv_video pkgconfig test
+SUBDIRS = va dummy_drv_video pkgconfig test debian.upstream
+
+# Extra clean files so that maintainer-clean removes *everything*
+MAINTAINERCLEANFILES = \
+ aclocal.m4 compile config.guess config.sub \
+ configure depcomp install-sh ltmain.sh \
+ Makefile.in missing
+
+DEB_BUILDDIR = debian.build
+
+deb:
+ @[ -d debian ] || ln -s debian.upstream debian
+ dpkg-buildpackage -rfakeroot -uc -us
+
+deb.upstream: dist
+ -mkdir -p $(DEB_BUILDDIR)
+ cd $(DEB_BUILDDIR) && \
+ rm -rf $(PACKAGE)-$(VERSION) && \
+ tar zxvf ../$(PACKAGE)-$(VERSION).tar.gz && \
+ cd $(PACKAGE)-$(VERSION) && \
+ $(MAKE) deb -f Makefile.am