summaryrefslogtreecommitdiff
path: root/i965_drv_video/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'i965_drv_video/Makefile.am')
-rw-r--r--i965_drv_video/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/i965_drv_video/Makefile.am b/i965_drv_video/Makefile.am
new file mode 100644
index 0000000..c0117c9
--- /dev/null
+++ b/i965_drv_video/Makefile.am
@@ -0,0 +1,52 @@
+# Copyright (c) 2007 Intel Corporation. All Rights Reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the
+# "Software"), to deal in the Software without restriction, including
+# without limitation the rights to use, copy, modify, merge, publish,
+# distribute, sub license, and/or sell copies of the Software, and to
+# permit persons to whom the Software is furnished to do so, subject to
+# the following conditions:
+#
+# The above copyright notice and this permission notice (including the
+# next paragraph) shall be included in all copies or substantial portions
+# of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT.
+# IN NO EVENT SHALL PRECISION INSIGHT AND/OR ITS SUPPLIERS BE LIABLE FOR
+# ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+# TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+# SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+SUBDIRS = shaders
+
+AM_CFLAGS = -Wall -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 @DRM_CFLAGS@ -DIN_LIBVA
+
+i965_drv_video_la_LTLIBRARIES = i965_drv_video.la
+i965_drv_video_ladir = @LIBVA_DRIVERS_PATH@
+i965_drv_video_la_LDFLAGS = -module -avoid-version -no-undefined -Wl,--no-undefined @DRM_LIBS@ -ldrm_intel
+i965_drv_video_la_LIBADD = ../src/libva.la -lpthread
+
+i965_drv_video_la_SOURCES = \
+ object_heap.c \
+ intel_batchbuffer.c \
+ intel_memman.c \
+ intel_driver.c \
+ i965_media.c \
+ i965_media_mpeg2.c \
+ i965_render.c \
+ i965_drv_video.c
+
+noinst_HEADERS = \
+ object_heap.h \
+ intel_batchbuffer.h \
+ intel_memman.h \
+ intel_driver.h \
+ i965_media.h \
+ i965_media_mpeg2.h \
+ i965_render.h \
+ i965_drv_video.h \
+ i965_defines.h \
+ i965_structs.h