summaryrefslogtreecommitdiff
path: root/test/egl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/egl/Makefile.am')
-rw-r--r--test/egl/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/egl/Makefile.am b/test/egl/Makefile.am
new file mode 100644
index 0000000..caf7126
--- /dev/null
+++ b/test/egl/Makefile.am
@@ -0,0 +1,15 @@
+bin_PROGRAMS = va_egl
+
+INCLUDES = -I$(top_srcdir)
+
+TEST_LIBS = $(top_builddir)/va/$(libvabackendlib) $(top_builddir)/va/$(libvacorelib) $(top_builddir)/va/libva-egl.la -lpthread -lX11 -lEGL -lGLESv1_CM
+
+va_egl_LDADD = $(TEST_LIBS)
+va_egl_SOURCES = va_egl_x11.c
+
+EXTRA_DIST =
+
+valgrind: $(bin_PROGRAMS)
+ for a in $(bin_PROGRAMS); do \
+ valgrind --leak-check=full --show-reachable=yes .libs/$$a; \
+ done