summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2011-01-27 15:16:14 -0700
committerEric Blake <eblake@redhat.com>2011-01-29 10:36:47 -0700
commit030ce43b4952a4ff37486f119caaea43f88f3699 (patch)
tree95fe758f37ec43e67e8a446692099553cd9bb215 /Makefile.am
parente67ae619919acb654b96a6829d9161287f814e71 (diff)
downloadlibvirt-030ce43b4952a4ff37486f119caaea43f88f3699.tar.gz
maint: reject raw close, popen in 'make syntax-check'
commit f1fe9671e was supposed to make sure we use files.h macros to avoid double close, but it didn't work. Meanwhile, virCommand is vastly superior to system(), fork(), and popen() (also to virExec, but we haven't completed that conversion), so enforce that, too. * cfg.mk (sc_prohibit_close): Fix typo that excluded close, and add pclose. (sc_prohibit_fork_wrappers): New rule, for fork, system, and popen. * .x-sc_prohibit_close: More exemptions. * .x-sc_prohibit_fork_wrappers: New file. * Makefile.am (syntax_check_exceptions): Ship new file. * src/datatypes.c (virReleaseConnect): Tweak comment to avoid false positive. * src/util/files.h (VIR_CLOSE): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 36463f5470..597ec6112c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,7 @@ syntax_check_exceptions = \
.x-sc_prohibit_asprintf \
.x-sc_prohibit_close \
.x-sc_prohibit_empty_lines_at_EOF \
+ .x-sc_prohibit_fork_wrappers \
.x-sc_prohibit_gethostby \
.x-sc_prohibit_gethostname \
.x-sc_prohibit_gettext_noop \