summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJiri Denemark <jdenemar@redhat.com>2012-12-14 16:14:15 +0100
committerJiri Denemark <jdenemar@redhat.com>2012-12-17 21:17:55 +0100
commit7f193f1f78e1ad976a2f3f65347af650d27f7632 (patch)
tree47b4ad380b34baa092d1aa33a4b84b41f6daa9e2 /Makefile.am
parentbc5b270c44db224b2ba2ebfe6368a43f18caeb00 (diff)
downloadlibvirt-7f193f1f78e1ad976a2f3f65347af650d27f7632.tar.gz
build: Fix AUTHORS generation
Using s/#authorslist#/$$out/ makes perl eat @domain part of all email addresses from $out since it tries to interpret them as array variables. I'm not sure if we can escape those in s/// but I know we can use print: s/#authorslist#// and print '$$out' to tell perl not to even look inside $out. This patch also fixes gen-AUTHORS so that it works in VPATH.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 9556b429de..5b1e27e319 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,9 +95,9 @@ gen-ChangeLog:
.PHONY: gen-AUTHORS
gen-AUTHORS:
- $(AM_V_GEN)if test -d .git; then \
- out="`git log --pretty=format:'%aN <%aE>' | sort -u`" && \
- cat $(srcdir)/AUTHORS.in | perl -p -e "s/#authorslist#/$$out/" > \
- $(distdir)/AUTHORS-tmp && \
+ $(AM_V_GEN)if test -d $(srcdir)/.git; then \
+ out="`cd $(srcdir) && git log --pretty=format:'%aN <%aE>' | sort -u`" && \
+ perl -p -e "s/#authorslist#// and print '$$out'" \
+ < $(srcdir)/AUTHORS.in > $(distdir)/AUTHORS-tmp && \
mv -f $(distdir)/AUTHORS-tmp $(distdir)/AUTHORS ; \
fi