summaryrefslogtreecommitdiff
path: root/libxklavier/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libxklavier/Makefile.am')
-rw-r--r--libxklavier/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/libxklavier/Makefile.am b/libxklavier/Makefile.am
index 64378e4..3eea793 100644
--- a/libxklavier/Makefile.am
+++ b/libxklavier/Makefile.am
@@ -16,6 +16,14 @@ endif
EXTRA_DIST=marshal.list
+GLIB_GENMARSHAL = $(shell pkg-config --variable=glib_genmarshal glib-2.0)
+
+xkl_engine_marshal.h: marshal.list
+ $(GLIB_GENMARSHAL) --prefix=xkl_engine marshal.list --header > xkl_engine_marshal.h
+
+xkl_engine_marshal.c: xkl_engine_marshal.h
+ $(GLIB_GENMARSHAL) --prefix=xkl_engine marshal.list --body > xkl_engine_marshal.c
+
AM_CFLAGS=-Wall -Werror -DDATA_DIR=\"$(datadir)/$(PACKAGE)\" \
-I. -I$(includedir) -I$(x_includes) -I$(top_srcdir) \
$(XML_CFLAGS) $(GLIB_CFLAGS) \