summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e6dd92c..1b47f33 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,9 +12,20 @@ maintainer-clean-local:
-rm -f aclocal.m4 config.h.in configure config/*
-find ${builddir} -name Makefile.in -exec rm -f '{}' ';'
+distclean-local:
+ -rm -fr libyaml-test
+
.PHONY: bootstrap
bootstrap: maintainer-clean
./bootstrap
test: all
make -C tests check-TESTS
+
+test-suite: libyaml-test
+ (export LIBYAML_DIR=$$PWD; make -C $< test)
+
+libyaml-test:
+ git clone https://github.com/yaml/$@
+
+test-all: test test-suite