summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2015-09-30 10:41:41 +1300
committerRobert Ancell <robert.ancell@canonical.com>2015-09-30 10:41:41 +1300
commit834efdc487cabddb13aea54efaa2dd742d96d93e (patch)
treeb918051105a1ac4baaa6284bcfc79dca0917513b /configure.ac
parent79841df29a948073948fd6979afa22d49ea5e39a (diff)
downloadlightdm-834efdc487cabddb13aea54efaa2dd742d96d93e.tar.gz
Change --enable-audit to --enable-libaudit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 1cbc7669..008b9753 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,21 +129,21 @@ if test x"$enable_liblightdm_qt5" != "xno"; then
fi
AM_CONDITIONAL(COMPILE_LIBLIGHTDM_QT5, test x"$compile_liblightdm_qt5" != "xno")
-AC_ARG_ENABLE([audit],
- AS_HELP_STRING([--enable-audit],
- [Enable audit logging of login and logout events [[default=auto]]]),
- [enable_audit=$enableval],
- [enable_audit=auto])
+AC_ARG_ENABLE([libaudit],
+ AS_HELP_STRING([--enable-libaudit],
+ [Enable libaudit logging of login and logout events [[default=auto]]]),
+ [enable_libaudit=$enableval],
+ [enable_libaudit=auto])
use_libaudit=no
-if test x"$enable_audit" != "xno"; then
+if test x"$enable_libaudit" != "xno"; then
AC_CHECK_LIB([audit], [audit_log_user_message],
[use_libaudit=yes
AC_DEFINE(HAVE_LIBAUDIT, 1, [libaudit support])
LIGHTDM_LIBS="${LIGHTDM_LIBS} -laudit"
],
- [if test "x$enable_audit" != xauto; then
+ [if test "x$enable_libaudit" != xauto; then
AC_MSG_FAILURE(
- [--enable-audit was given, but test for libaudit failed])
+ [--enable-libaudit was given, but test for libaudit failed])
fi
])
fi