summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2015-09-16 13:45:20 -0400
committerRobert Ancell <robert.ancell@canonical.com>2015-09-16 13:45:20 -0400
commit6c3293a54bd33625d6b78e13d0cb9d80e85c843a (patch)
tree70e909b44b2e66ece1535bc7df074f9f8867dedf /configure.ac
parent681d06afbd576a7ebc4f865ab42bdc3c9cd40c19 (diff)
downloadlightdm-6c3293a54bd33625d6b78e13d0cb9d80e85c843a.tar.gz
Log at configure time if libaudit is being used
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 27a0e096..1cbc7669 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,9 +134,11 @@ AC_ARG_ENABLE([audit],
[Enable audit logging of login and logout events [[default=auto]]]),
[enable_audit=$enableval],
[enable_audit=auto])
+use_libaudit=no
if test x"$enable_audit" != "xno"; then
AC_CHECK_LIB([audit], [audit_log_user_message],
- [AC_DEFINE(HAVE_LIBAUDIT, 1, [libaudit support])
+ [use_libaudit=yes
+ AC_DEFINE(HAVE_LIBAUDIT, 1, [libaudit support])
LIGHTDM_LIBS="${LIGHTDM_LIBS} -laudit"
],
[if test "x$enable_audit" != xauto; then
@@ -242,5 +244,6 @@ echo "
Vala bindings: $enable_vala
liblightdm-qt: $compile_liblightdm_qt4
liblightdm-qt5: $compile_liblightdm_qt5
+ libaudit support: $use_libaudit
Enable tests: $enable_tests
"