summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2014-01-07 11:26:36 +1300
committerRobert Ancell <robert.ancell@canonical.com>2014-01-07 11:26:36 +1300
commit721056829c5ebe95c64bbd9b65a010ea8b67ab3a (patch)
tree826edb2f7505553db3c05e4abbd20fe1600fda32 /configure.ac
parent4c09fe59122e7298668fe85317baca68bb13f7ad (diff)
downloadlightdm-721056829c5ebe95c64bbd9b65a010ea8b67ab3a.tar.gz
Don't try to compile liblightdm-qt if liblightdm-gobject will not be compiled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 34748188..b12ae291 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,7 +96,7 @@ AC_ARG_ENABLE(liblightdm-qt,
[enable_liblightdm_qt4=$enableval],
[enable_liblightdm_qt4="auto"])
compile_liblightdm_qt4=no
-if test x"$enable_liblightdm_qt4" != "xno"; then
+if test x"$enable_liblightdm_qt4" = "xyes" -o \( x"$enable_liblightdm_qt4" = "xauto" -a x$compile_liblightdm_gobject = xyes \) ; then
PKG_CHECK_MODULES(LIBLIGHTDM_QT4, [
QtCore
QtDBus
@@ -107,6 +107,10 @@ if test x"$enable_liblightdm_qt4" != "xno"; then
if test x"$(readlink $(which $MOC4))" = xqtchooser; then
MOC4="$MOC4 --qt=qt4"
fi
+ if test "x$compile_liblightdm_gobject" != xyes; then
+ AC_MSG_FAILURE(
+ [liblightdm-gobject is required to compile liblightdm-qt])
+ fi
],
[if test "x$enable_liblightdm_qt4" != xauto; then
AC_MSG_FAILURE(