summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2011-06-14 13:04:06 +1000
committerRobert Ancell <robert.ancell@canonical.com>2011-06-14 13:04:06 +1000
commit83a43b7c9e4325398da660437375fc42400e4885 (patch)
tree4e909113ba995249df39c2a417bf5fb699effd30 /configure.ac
parent54b8de0ea0cf8ef08c65b757a70086801e247176 (diff)
downloadlightdm-83a43b7c9e4325398da660437375fc42400e4885.tar.gz
Automatic login users now use PAM session lightdm-autologin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8b9acb5..4216a3e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,6 +223,17 @@ AC_ARG_WITH(default-pam-service,
AC_SUBST(DEFAULT_PAM_SERVICE)
AC_DEFINE_UNQUOTED(DEFAULT_PAM_SERVICE, "$DEFAULT_PAM_SERVICE", Default PAM service to use)
+DEFAULT_PAM_AUTOLOGIN_SERVICE=lightdm-autologin
+AC_ARG_WITH(default-pam-autologin-service,
+ AS_HELP_STRING(--with-default-pam-autologin-service=<name>,
+ Default PAM service to use for automatic logins),
+ if test x$withval != x; then
+ DEFAULT_PAM_AUTOLOGIN_SERVICE="$withval"
+ fi
+)
+AC_SUBST(DEFAULT_PAM_AUTOLOGIN_SERVICE)
+AC_DEFINE_UNQUOTED(DEFAULT_PAM_AUTOLOGIN_SERVICE, "$DEFAULT_PAM_AUTOLOGIN_SERVICE", Default PAM service to use for automatic logins)
+
GREETER_THEME_DIR=${datarootdir}/lightdm/themes
AC_ARG_WITH(greeter-theme-dir,
AS_HELP_STRING(--with-greeter-theme-dir=<dir>,
@@ -308,6 +319,7 @@ echo "
Default X session: $DEFAULT_XSESSION
Greeter user: $GREETER_USER
PAM service: $DEFAULT_PAM_SERVICE
+ PAM service (autologins): $DEFAULT_PAM_AUTOLOGIN_SERVICE
Greeter theme directory: $GREETER_THEME_DIR
Default greeter theme: $DEFAULT_GREETER_THEME