summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRobert Ancell <robert.ancell@canonical.com>2015-10-12 15:06:40 +0100
committerRobert Ancell <robert.ancell@canonical.com>2015-10-12 15:06:40 +0100
commitba35a763841151b80a80a43e3e009beaa620aaa9 (patch)
tree5cb7f4056c79520a469e2c8f65e2a9a15c6a6d0d /debian
parent5a1e53362392835eac2c47d9d1c8e1378288decf (diff)
downloadlightdm-ba35a763841151b80a80a43e3e009beaa620aaa9.tar.gz
* debian/patches/xorg-1.17.patch:
- Fix xserver-allow-tcp=true option not working with X.org 1.17
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/xorg-1.17.patch26
3 files changed, 34 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 640b9b21..4e797168 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+lightdm (1.17.0-0ubuntu1) UNRELEASED; urgency=medium
+
+ * debian/patches/xorg-1.17.patch:
+ - Fix xserver-allow-tcp=true option not working with X.org 1.17
+
+ -- Robert Ancell <robert.ancell@canonical.com> Mon, 12 Oct 2015 14:57:47 +0100
+
lightdm (1.16.0-0ubuntu1) wily; urgency=medium
* New upstream release:
diff --git a/debian/patches/series b/debian/patches/series
index d3ba2550..7f14c0ad 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
04_language_handling.patch
05_translate_debian_files.patch
autologin-session-workaround.patch
+xorg-1.17.patch
diff --git a/debian/patches/xorg-1.17.patch b/debian/patches/xorg-1.17.patch
new file mode 100644
index 00000000..9f7ecfd2
--- /dev/null
+++ b/debian/patches/xorg-1.17.patch
@@ -0,0 +1,26 @@
+Description: The X.org X server 1.17 doesn't listen on TCP by default, we need to pass -listen to enable it
+Author: Robert Ancell <robert.ancell@canonical.com>
+Bug: https://bugs.launchpad.net/bugs/1449282
+
+=== modified file 'src/x-server-local.c'
+Index: 1.16/src/x-server-local.c
+===================================================================
+--- 1.16.orig/src/x-server-local.c
++++ 1.16/src/x-server-local.c
+@@ -477,6 +477,7 @@ x_server_local_start (DisplayServer *dis
+ /* Connect to a remote server using XDMCP */
+ if (server->priv->xdmcp_server != NULL)
+ {
++ g_string_append (command, " -listen tcp");
+ if (server->priv->xdmcp_port != 0)
+ g_string_append_printf (command, " -port %d", server->priv->xdmcp_port);
+ g_string_append_printf (command, " -query %s", server->priv->xdmcp_server);
+@@ -485,6 +486,8 @@ x_server_local_start (DisplayServer *dis
+ }
+ else if (!server->priv->allow_tcp)
+ g_string_append (command, " -nolisten tcp");
++ else
++ g_string_append (command, " -listen tcp");
+
+ if (server->priv->vt >= 0)
+ g_string_append_printf (command, " vt%d -novtswitch", server->priv->vt);