summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMichael Terry <michael.terry@canonical.com>2014-03-17 22:05:57 -0400
committerMichael Terry <michael.terry@canonical.com>2014-03-17 22:05:57 -0400
commit9ee502417ce58ab161b86ecca91b954663ca1b31 (patch)
treea869b94ce289eb30ec213574c2e41a3ce751fec0 /src/Makefile.am
parent7eb48d9cba1ac45532b51b0953a59dbfe72ba9a0 (diff)
downloadlightdm-9ee502417ce58ab161b86ecca91b954663ca1b31.tar.gz
Move config loading into one function; move that function into libcommon; call it from liblightdm too
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ba35eeaf..da16d630 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,12 +78,10 @@ lightdm_CFLAGS = \
$(LIGHTDM_CFLAGS) \
-I"$(top_srcdir)/common" \
-DSBIN_DIR=\"$(sbindir)\" \
- -DCONFIG_DIR=\"$(sysconfdir)/lightdm\" \
-DUSERS_DIR=\"$(localstatedir)/lib/lightdm-data\" \
-DLOG_DIR=\"$(localstatedir)/log/lightdm\" \
-DRUN_DIR=\"$(localstatedir)/run/lightdm\" \
-DCACHE_DIR=\"$(localstatedir)/cache/lightdm\" \
- -DSYSTEM_CONFIG_DIR=\"$(pkgdatadir)/lightdm.conf.d\" \
-DSESSIONS_DIR=\"$(pkgdatadir)/sessions:$(datadir)/xsessions\" \
-DREMOTE_SESSIONS_DIR=\"$(pkgdatadir)/remote-sessions\" \
-DGREETERS_DIR=\"$(pkgdatadir)/greeters:$(datadir)/xgreeters\"
@@ -100,7 +98,6 @@ dm_tool_SOURCES = \
dm_tool_CFLAGS = \
$(WARN_CFLAGS) \
$(LIGHTDM_CFLAGS) \
- -DCONFIG_DIR=\"$(sysconfdir)/lightdm\" \
-DLOCALE_DIR=\"$(datadir)/locale\"
dm_tool_LDADD = \