summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2016-09-29 20:30:49 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2016-10-04 05:03:15 -0400
commit06cb0c30249ba212f55ed0a8fcb0b20bc733d2de (patch)
tree14fb1ed6eb4350556155ee102523e7aea529e939 /configure.ac
parent8b282db1d15e11655b1d7f69dc7cb9ceeba3bcbf (diff)
downloadlighttpd-git-06cb0c30249ba212f55ed0a8fcb0b20bc733d2de.tar.gz
[autobuild] update module/feature report
update module/feature report at end of ./configure run
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cee52208..f5e2efa9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -905,7 +905,7 @@ AC_CONFIG_FILES([Makefile src/Makefile
AC_OUTPUT
-do_build="mod_cgi mod_fastcgi mod_extforward mod_proxy mod_evhost mod_simple_vhost mod_access mod_alias mod_setenv mod_usertrack mod_auth mod_status mod_accesslog"
+do_build="mod_cgi mod_fastcgi mod_extforward mod_proxy mod_evhost mod_simple_vhost mod_access mod_alias mod_setenv mod_usertrack mod_auth mod_authn_file mod_authn_ldap mod_authn_mysql mod_status mod_accesslog"
do_build="$do_build mod_rrdtool mod_secdownload mod_expire mod_compress mod_dirlisting mod_indexfile mod_userdir mod_webdav mod_staticfile mod_scgi mod_flv_streaming mod_ssi mod_deflate"
plugins="mod_rewrite mod_redirect mod_trigger_b4_dl"
@@ -918,11 +918,14 @@ else
disable_feature="$features"
fi
+features="auth-mysql"
plugins="mod_mysql_vhost"
if test ! "x$MYSQL_LIBS" = x; then
do_build="$do_build $plugins"
+ enable_feature="$enable_feature $features"
else
no_build="$no_build $plugins"
+ disable_feature="$disable_feature $features"
fi
plugins="mod_cml mod_magnet"
@@ -960,6 +963,16 @@ else
disable_feature="$disable_feature $features"
fi
+features="auth-krb5"
+plugins="mod_authn_gssapi"
+if test ! "x$KRB5_LIB" = x; then
+ do_build="$do_build $plugins"
+ enable_feature="$enable_feature $features"
+else
+ no_build="$no_build $plugins"
+ disable_feature="$disable_feature $features"
+fi
+
features="auth-ldap"
if test ! "x$LDAP_LIB" = x; then
enable_feature="$enable_feature $features"