summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2016-12-21 04:23:49 -0500
committerGlenn Strauss <gstrauss@gluelogic.com>2017-01-14 01:06:16 -0500
commitcb9ebe9fa6d5203ffcc57c2fbef1820fb4b03689 (patch)
treeb47bdb3d7c1064a086d4a0fad201112ef52e1964 /configure.ac
parentcb7ed13621691e528adcf0e087fae5b86c614e28 (diff)
downloadlighttpd-git-cb9ebe9fa6d5203ffcc57c2fbef1820fb4b03689.tar.gz
[mod_openssl] new module (preliminary layout)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e14cba85..640671fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -383,6 +383,7 @@ else
use_openssl=no
fi
AC_MSG_RESULT([$use_openssl])
+AM_CONDITIONAL(BUILD_WITH_OPENSSL, test ! $WITH_OPENSSL = no)
AC_ARG_WITH(openssl-includes,
AC_HELP_STRING([--with-openssl-includes=DIR],[OpenSSL includes]),
@@ -403,10 +404,12 @@ if test "x$use_openssl" = "xyes"; then
OLDLIBS="$LIBS"
AC_CHECK_LIB(crypto, BIO_f_base64, [
AC_CHECK_LIB(ssl, SSL_new, [ SSL_LIB="-lssl -lcrypto"
+ CRYPTO_LIB="-lcrypto"
AC_DEFINE(HAVE_LIBSSL, [], [Have libssl]) ], [], [ -lcrypto "$DL_LIB" ])
], [], [])
LIBS="$OLDLIBS"
AC_SUBST(SSL_LIB)
+ AC_SUBST(CRYPTO_LIB)
fi
AC_MSG_CHECKING(for perl regular expressions support)