summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2016-05-07 12:41:05 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2016-05-07 12:50:41 -0400
commit1ca52fdce3b87f7748dd5db6f59d738ed7a9efe1 (patch)
treef2909dafbfbf144494132e6c67a57fe1245be991 /configure.ac
parent873eaf3f4ad9b56150d2c370c4a3ab98e5b7ce90 (diff)
downloadlighttpd-git-1ca52fdce3b87f7748dd5db6f59d738ed7a9efe1.tar.gz
build with libressl
libressl defines SSL_OP_NO_SSLv2 and SSL_OP_NO_SSLv3 as 0x0 (thx Christian Heckendorf) libressl matches ERR_remove_thread_state() signature from openssl 1.0.2 (libressl pretends that libressl is openssl version 2.0.0, but openssl 1.1.0 changes signature of ERR_remove_thread_state()) libressl does not yet provide compatibility interfaces for the new prototypes introduced in openssl 1.1.0, including DH_set0_pqg() and DH_set_length() remove OPENSSL_NO_KRB5 from build config (added in 5fab991b in 2005) (define USE_OPENSSL_KERBEROS if required) (Note: OPENSSL_NO_KRB5 removed in openssl 1.1.0)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b7a0a67a..6fe4b044 100644
--- a/configure.ac
+++ b/configure.ac
@@ -346,8 +346,8 @@ AC_ARG_WITH(kerberos5,
)
if test "x$use_openssl" = "xyes"; then
- if test "x$use_kerberos" != "xyes"; then
- CPPFLAGS="$CPPFLAGS -DOPENSSL_NO_KRB5"
+ if test "x$use_kerberos" = "xyes"; then
+ AC_DEFINE([USE_OPENSSL_KERBEROS], [1], [with kerberos])
fi
AC_CHECK_HEADERS([openssl/ssl.h])