summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Bühler <stbuehler@web.de>2016-01-03 14:48:09 +0000
committerStefan Bühler <stbuehler@web.de>2016-01-03 14:48:09 +0000
commitc354229f42ac1a21746a5700d00d1745310cd740 (patch)
treeaaf437490b3d1b5b0d191dcae96cf587bdf0e327 /src/CMakeLists.txt
parentd8e028e06900b781bebfe2f52cc7254444a31716 (diff)
downloadlighttpd-git-c354229f42ac1a21746a5700d00d1745310cd740.tar.gz
add handling for lua 5.2 and 5.3 (fixes #2674)
Reviewers: stbuehler Differential Revision: https://review.lighttpd.net/D4 From: Stefan Bühler <stbuehler@web.de> git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@3070 152afb58-edef-0310-8abb-c4023f1b3aa9
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a4deeba8..613af887 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -397,7 +397,7 @@ else()
endif()
if(WITH_LUA)
- pkg_search_module(LUA REQUIRED lua lua5.1 lua-5.1)
+ pkg_search_module(LUA REQUIRED lua5.3 lua-5.3 lua5.2 lua-5.2 lua5.1 lua-5.1 lua)
message(STATUS "found lua at: INCDIR: ${LUA_INCLUDE_DIRS} LIBDIR: ${LUA_LIBRARY_DIRS} LDFLAGS: ${LUA_LDFLAGS} CFLAGS: ${LUA_CFLAGS}")
set(HAVE_LIBLUA 1 "Have liblua")
set(HAVE_LUA_H 1 "Have liblua header")