summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2016-10-13 03:10:10 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2016-10-15 23:28:09 -0400
commit7f4e156e5f12093071e8746cd9702827a66952ed (patch)
treec46f12be6f48cd5c2e2ba7f8dfe7768f80a7e699 /src/Makefile.am
parentb8b38f306790a48db7e0e7a61ba6bb18114eba05 (diff)
downloadlighttpd-git-7f4e156e5f12093071e8746cd9702827a66952ed.tar.gz
[core] rand.[ch] to use better RNGs when available
prefer RAND_pseudo_bytes() (openssl), arc4random() or jrand48(), if available, over rand() These are not necessarily cryptographically secure, but should be better than rand()
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dfdc8b27..5efa0347 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -82,6 +82,7 @@ common_src=base64.c buffer.c log.c \
network_write_mmap.c network_write_no_mmap.c \
network_freebsd_sendfile.c network_writev.c \
network_solaris_sendfilev.c network_openssl.c \
+ rand.c \
splaytree.c status_counter.c \
safe_memclear.c network_darwin_sendfile.c
@@ -324,6 +325,7 @@ hdr = server.h base64.h buffer.h network.h log.h keyvalue.h \
network_backends.h configfile.h \
mod_ssi.h mod_ssi_expr.h inet_ntop_cache.h \
configparser.h mod_ssi_exprparser.h \
+ rand.h \
sys-endian.h sys-mmap.h sys-socket.h mod_cml.h mod_cml_funcs.h \
safe_memclear.h splaytree.h proc_open.h status_counter.h \
mod_magnet_cache.h \