summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2017-07-25 02:05:36 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2017-07-25 02:07:49 -0400
commit889db409dcdd26de432b51e08fa7999ea902ffe4 (patch)
tree2b508e8da9057c6cf08d44fea70c071fef798afb /src/Makefile.am
parentfad841d69bc068b89074b1e6a8bbd2baac85116a (diff)
downloadlighttpd-git-889db409dcdd26de432b51e08fa7999ea902ffe4.tar.gz
[core] add public domain SHA1() if no crypto
add public domain SHA1() if not linking with crypto lib obtained from https://github.com/nori0428/mod_websocket * Originally written by Steve Reid <steve@edmweb.com> * * Modified by Aaron D. Gifford <agifford@infowest.com> * * NO COPYRIGHT - THIS IS 100% IN THE PUBLIC DOMAIN * * The original unmodified version is available at: * ftp://ftp.funet.fi/pub/crypt/hash/sha/sha1.c
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 892dcf2d..dc12aee9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -60,7 +60,7 @@ common_src=base64.c buffer.c log.c \
http_chunk.c stream.c fdevent.c gw_backend.c \
stat_cache.c plugin.c joblist.c etag.c array.c \
data_string.c data_array.c \
- data_integer.c md5.c \
+ data_integer.c algo_sha1.c md5.c \
vector.c \
fdevent_select.c fdevent_libev.c \
fdevent_poll.c fdevent_linux_sysepoll.c \
@@ -374,7 +374,7 @@ mod_uploadprogress_la_LIBADD = $(common_libadd)
hdr = server.h base64.h buffer.h network.h log.h keyvalue.h \
response.h request.h fastcgi.h chunk.h \
first.h settings.h http_chunk.h \
- md5.h http_auth.h http_vhostdb.h stream.h \
+ algo_sha1.h md5.h http_auth.h http_vhostdb.h stream.h \
fdevent.h gw_backend.h connections.h base.h stat_cache.h \
plugin.h \
etag.h joblist.h array.h vector.h crc32.h \