summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2017-05-09 18:56:30 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2017-05-15 22:02:32 -0400
commit8913dc4e59dafb862b5e3cd193f19fb41ee78bd5 (patch)
tree787246c70725c452478d0a9e69024da42d0fbeec /src/Makefile.am
parent14656f8f8910db74009dcb81b26ed3a93c166ed8 (diff)
downloadlighttpd-git-8913dc4e59dafb862b5e3cd193f19fb41ee78bd5.tar.gz
[mod_extforward] compile on OSX
define MSG_DONTWAIT and MSG_NOSIGNAL to be no-ops on platforms without support. (fd should already be configured O_NONBLOCK and SIGPIPE signal is configured to be ignored) (thx avij and wardw)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b07a9cb2..c8c478c4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -74,6 +74,7 @@ common_src=base64.c buffer.c log.c \
http_auth.c \
http_vhostdb.c \
rand.c \
+ request.c \
splaytree.c status_counter.c \
safe_memclear.c
@@ -83,7 +84,7 @@ src = server.c response.c connections.c network.c \
network_freebsd_sendfile.c network_writev.c \
network_solaris_sendfilev.c \
network_darwin_sendfile.c \
- configfile.c configparser.c request.c proc_open.c
+ configfile.c configparser.c proc_open.c
lib_LTLIBRARIES =