summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2022-01-05 08:29:10 +0000
committerGlenn Strauss <gstrauss@gluelogic.com>2022-01-05 06:52:24 -0500
commitb6bd11c15e62133426cf2acf189886237b97736c (patch)
tree3a7df593325fc5c8347165e2aedba0364163cea1 /src/meson.build
parent3d0f64894823476165b7b31d5a508899cbfe2bec (diff)
downloadlighttpd-git-b6bd11c15e62133426cf2acf189886237b97736c.tar.gz
[core] server.core-files support for solaris (fixes #3135)
server.core-files support for solaris based systems. - using setpflags and disable process tracing protection for the current process. (edited: gstrauss) x-ref: "server.core-files support on Solaris based system" https://redmine.lighttpd.net/issues/3135
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 034c7452..bfe6a29c 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -118,6 +118,11 @@ if conf_data.get('HAVE_LINUX_RANDOM_H')
))
endif
+if target_machine.system() == 'sunos'
+conf_data.set('HAVE_PRIV_H', compiler.has_header('priv.h'))
+conf_data.set('HAVE_SETPFLAGS', compiler.has_function('setpflags', args: defs))
+endif
+
conf_data.set('SIZEOF_LONG', compiler.sizeof('long', args: defs))
conf_data.set('SIZEOF_OFF_T', compiler.sizeof('off_t', args: defs))