summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ceccad74..36e015d1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -982,6 +982,13 @@ endif()
if(HAVE_DBI_H AND HAVE_DBI)
add_and_install_library(mod_vhostdb_dbi "mod_vhostdb_dbi.c")
target_link_libraries(mod_vhostdb_dbi dbi)
+
+ add_and_install_library(mod_authn_dbi "mod_authn_dbi.c")
+ set(L_MOD_AUTHN_DBI)
+ if(HAVE_LIBCRYPT)
+ set(L_MOD_AUTHN_DBI ${L_MOD_AUTHN_DBI} crypt)
+ endif()
+ target_link_libraries(mod_authn_dbi ${L_MOD_AUTHN_DBI} dbi)
endif()
set(L_MOD_WEBDAV)