summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index e10faece..8e084edc 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -297,11 +297,10 @@ libldap = []
liblber = []
if get_option('with_ldap')
libldap = [ compiler.find_library('ldap') ]
- if not(compiler.has_function('ldap_bind',
+ if not(compiler.has_function('ldap_sasl_bind_s',
args: defs,
dependencies: libldap,
prefix: '''
- #define LDAP_DEPRECATED 1
#include <ldap.h>
'''
))
@@ -315,7 +314,6 @@ if get_option('with_ldap')
endif
conf_data.set('HAVE_LBER_H', true)
conf_data.set('HAVE_LIBLBER', true)
- conf_data.set('LDAP_DEPRECATED', 1, comment: 'Using deprecated ldap api')
endif
libev = []