summaryrefslogtreecommitdiff
path: root/polly/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Kruse <llvm@meinersbur.de>2015-09-14 16:59:50 +0000
committerMichael Kruse <llvm@meinersbur.de>2015-09-14 16:59:50 +0000
commit69f3788c36f90432cf130fa974fffc517d241742 (patch)
treedbae596a8573b1c03e069ce91c76a638c4cf6075 /polly/CMakeLists.txt
parent64aa388efaff48652ac235c6e6edab86f9a8df33 (diff)
downloadllvm-69f3788c36f90432cf130fa974fffc517d241742.tar.gz
Revise polly-{update|check}-format targets
Summary: Make clang-format run on each file independently using add_custom_format (instead using a shell script in utils/). The targets polly-{update|check}-format depend on these. The primary motivation is to make them work on Windows, but also improves them generally: - Each file update/check can run in parallel (Although they do not take long to run anyway) - Implicit dependency on clang-format, so it recompiles if necessary - polly-check-format shows the formatting difference if failing Differential Revision: http://reviews.llvm.org/D12837 llvm-svn: 247581
Diffstat (limited to 'polly/CMakeLists.txt')
-rw-r--r--polly/CMakeLists.txt33
1 files changed, 25 insertions, 8 deletions
diff --git a/polly/CMakeLists.txt b/polly/CMakeLists.txt
index a020571f8a44..20209e953f44 100644
--- a/polly/CMakeLists.txt
+++ b/polly/CMakeLists.txt
@@ -188,15 +188,32 @@ file( GLOB_RECURSE islfiles lib/External/isl/*.h lib/External/isl/*.c
lib/External/isl/include/isl/*.h lib/External/isl/imath/*.h
lib/External/isl/imath/*.c)
list( REMOVE_ITEM files ${jsonfiles} ${islfiles})
-add_custom_command( OUTPUT formatting COMMAND
- CLANG_FORMAT=${LLVM_BINARY_DIR}/bin/clang-format
- ${CMAKE_CURRENT_SOURCE_DIR}/utils/check_format.sh ${files})
-add_custom_target(polly-check-format DEPENDS formatting)
+
+set(check_format_depends)
+set(update_format_depends)
+set(i 0)
+foreach (file IN LISTS files)
+ add_custom_command(OUTPUT polly-check-format${i}
+ COMMAND clang-format -style=llvm ${file} | diff -u ${file} -
+ VERBATIM
+ COMMENT "Checking format of ${file}..."
+ )
+ list(APPEND check_format_depends "polly-check-format${i}")
+
+ add_custom_command(OUTPUT polly-update-format${i}
+ COMMAND clang-format -i -style=llvm ${file}
+ VERBATIM
+ COMMENT "Updating format of ${file}..."
+ )
+ list(APPEND update_format_depends "polly-update-format${i}")
+
+ math(EXPR i ${i}+1)
+endforeach ()
+
+add_custom_target(polly-check-format DEPENDS ${check_format_depends})
set_target_properties(polly-check-format PROPERTIES FOLDER "Polly")
-add_custom_command( OUTPUT formatting-update COMMAND
- CLANG_FORMAT=${LLVM_BINARY_DIR}/bin/clang-format
- ${CMAKE_CURRENT_SOURCE_DIR}/utils/update_format.sh ${files})
-add_custom_target(polly-update-format DEPENDS formatting-update)
+
+add_custom_target(polly-update-format DEPENDS ${update_format_depends})
set_target_properties(polly-update-format PROPERTIES FOLDER "Polly")
# Set the variable POLLY_LINK_LIBS in the llvm/tools/ dir.