summaryrefslogtreecommitdiff
path: root/polly/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Kruse <llvm@meinersbur.de>2015-06-22 17:52:33 +0000
committerMichael Kruse <llvm@meinersbur.de>2015-06-22 17:52:33 +0000
commitee512e58a32f6a653ab47f2c8272e459b03c0bd8 (patch)
treeb9ea81020c0b9cb111982e4165b02e5a8be2aa32 /polly/CMakeLists.txt
parent36b718fc74530d9a7e58185efa78fedbee7f5a13 (diff)
downloadllvm-ee512e58a32f6a653ab47f2c8272e459b03c0bd8.tar.gz
Prepare replacing ISL by its 'make dist' files
Currently the Polly repository contains the ISL sources with bogus isl_config.h and gitversion.h. This is problematic. In this state a macro #define __attribute__(x) becomes active in the source, leading to various problems e.g. when included before system header files. This patch will instead generate the two files specific to the host system at configure-time. For CMake, we replicate the tests that ISL's configure performs using try_compile(). In autotools build, we just invoke ISL's configure to generate the two files. This consequently required regenerating autoconf/configure. 'make dist' distributions of ISL contain a file GIT_HEAD_ID which contains the version the distribution is derived from. The repository files themselves do not contain such a hint. In a later commit we will replace the isl directory by the contents of such a .tar.gz. It does not contain the files imdrover.c iprime.c pi.c and rsamath.c currently compiled into Polly, but not used and therefore are removed by this patch. In the long term we plan to generate a dedicated library for ISL instead of adding its files to Polly. This also does not yet include the switch to small-integer optimized ISL nor enabling C99 mode required for the former. Those will come as well in separate patches. Differential version: http://reviews.llvm.org/D10603 Reviewers: grosser llvm-svn: 240301
Diffstat (limited to 'polly/CMakeLists.txt')
-rw-r--r--polly/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/polly/CMakeLists.txt b/polly/CMakeLists.txt
index 80fc6d3dff17..cb7b91f4a317 100644
--- a/polly/CMakeLists.txt
+++ b/polly/CMakeLists.txt
@@ -114,6 +114,7 @@ include_directories(
BEFORE
${CMAKE_CURRENT_SOURCE_DIR}/include
${CMAKE_CURRENT_SOURCE_DIR}/lib/JSON/include
+ ${CMAKE_CURRENT_BINARY_DIR}/lib/External/isl
${CMAKE_CURRENT_SOURCE_DIR}/lib/External/isl/include
${CMAKE_CURRENT_SOURCE_DIR}/lib/External/isl/imath
${CMAKE_CURRENT_SOURCE_DIR}/lib/External/isl