summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZdenek Kabelac <zkabelac@redhat.com>2018-12-03 18:14:26 +0100
committerZdenek Kabelac <zkabelac@redhat.com>2018-12-14 15:09:13 +0100
commit0b19387dae782b33bb341e58ab3c7ff804ca4f14 (patch)
treea3914adc8ac8141e4380fbe6b20efc7307067030 /configure.ac
parent3c377643339be97940554323909d51b12c933f9e (diff)
downloadlvm2-0b19387dae782b33bb341e58ab3c7ff804ca4f14.tar.gz
headers: use configure.h as 1st. header
Ensure configure.h is always 1st. included header. Maybe we could eventually introduce gcc -include option, but for now this better uses dependency tracking. Also move _REENTRANT and _GNU_SOURCE into configure.h so it doesn't need to be present in various source files. This ensures consistent compilation of headers like stdio.h since it may produce different declaration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b2921078..2ece3f963 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,6 +144,11 @@ AC_TYPE_UINT64_T
AX_GCC_BUILTIN([__builtin_clz])
AX_GCC_BUILTIN([__builtin_clzll])
+
+AC_DEFINE([_GNU_SOURCE], 1, [Define to get access to GNU/Linux extension])
+AC_DEFINE([_REENTRANT], 1, [Define to use re-entrant thread safe versions])
+
+
################################################################################
dnl -- Check for functions
AC_CHECK_FUNCS([ftruncate gethostname getpagesize gettimeofday localtime_r \