summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2011-05-15 13:38:18 +0200
committerVladislav Vaintroub <wlad@montyprogram.com>2011-05-15 13:38:18 +0200
commit19f0d6b2d9930f83688943b8f98a8b7397584df9 (patch)
tree08c9b040b07dfcf337c7a94244b0dd5ff5ccb7ff /CMakeLists.txt
parent2982738e48cf47162251d318c44b13801ea4804f (diff)
downloadmariadb-git-19f0d6b2d9930f83688943b8f98a8b7397584df9.tar.gz
Small CMake fixes :
- add version info for the client library, dynamic plugins and some utilities - do not recompile client library sources 3 times (for mysqlclient , mysqlclient_notls and libmysql) One time is sufficient, so get rid of mysqlclient_notls, and link static client library to the shared. - remove incremental linking flag
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dc753f1a85..3c6a65505fe 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,15 +171,7 @@ IF(MSVC)
IF(CMAKE_SIZEOF_VOID_P MATCHES 4)
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /LARGEADDRESSAWARE")
ENDIF(CMAKE_SIZEOF_VOID_P MATCHES 4)
-
- # Disable automatic manifest generation.
- STRING(REPLACE "/MANIFEST" "/MANIFEST:NO" CMAKE_EXE_LINKER_FLAGS
- ${CMAKE_EXE_LINKER_FLAGS})
- # Explicitly disable it since it is the default for newer versions of VS
- STRING(REGEX MATCH "MANIFEST:NO" tmp_manifest ${CMAKE_EXE_LINKER_FLAGS})
- IF(NOT tmp_manifest)
- SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MANIFEST:NO")
- ENDIF(NOT tmp_manifest)
+ SET (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /INCREMENTAL:NO")
ENDIF(MSVC)
IF(WIN32)