summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Black <grooverdan@users.sourceforge.net>2015-09-17 22:16:19 +1000
committerSergey Vojtovich <svoj@mariadb.org>2015-10-12 17:51:49 +0200
commit20c2ae39db3dd0ec4c337a9b0bd2bf4481b61e49 (patch)
treeb7764b7bcbae69da067c1d16592fdde2d82707ab /CMakeLists.txt
parent92271c78b6c78b1a0248ce5d1c96326b930de610 (diff)
downloadmariadb-git-20c2ae39db3dd0ec4c337a9b0bd2bf4481b61e49.tar.gz
MDEV-427/MDEV-5713 Add systemd script with notify functionality
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6df6e736bbd..8057114c1c0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,6 +151,7 @@ INCLUDE(pcre)
INCLUDE(ctest)
INCLUDE(plugin)
INCLUDE(install_macros)
+INCLUDE(systemd)
INCLUDE(mysql_add_executable)
# Handle options
@@ -328,6 +329,8 @@ CHECK_JEMALLOC()
CHECK_PCRE()
+CHECK_SYSTEMD()
+
IF(CMAKE_CROSSCOMPILING)
SET(IMPORT_EXECUTABLES "IMPORTFILE-NOTFOUND" CACHE FILEPATH "Path to import_executables.cmake from a native build")
INCLUDE(${IMPORT_EXECUTABLES})