summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2011-06-12 16:07:18 +0200
committerVladislav Vaintroub <wlad@montyprogram.com>2011-06-12 16:07:18 +0200
commit4bca1a786f9986cec7d0487059451e51e2b9479b (patch)
treee1a921bf2ce1ed21b1fe8a26435e4a1ea8268ea2 /CMakeLists.txt
parent824ce5f3eae52ee418665211c24218a5772c43f2 (diff)
downloadmariadb-git-4bca1a786f9986cec7d0487059451e51e2b9479b.tar.gz
Fix XtraDB LPBug #714143 :
Windows native async io is disabled. The patch uses completion ports for asynchronous IO notification , instead of formerly used notification via event . This also removes the limit of 64 async IOs per background IO thread (this limit was forced by using WaitForMultipleObjects in previous AIO implementation)
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c6a65505fe..9d4df51bcb1 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,7 @@ IF (MSVC_VERSION GREATER 1400)
ENDIF()
-SET(CMAKE_INSTALL_PREFIX "C:/MariaDB${MYSQL_BASE_VERSION}")
+SET(CMAKE_INSTALL_PREFIX "C:/MariaDB${MYSQL_BASE_VERSION}" CACHE PATH "Default installation directory")
SET(INSTALL_ROOT "${CMAKE_INSTALL_PREFIX}")
# Set standard options
ADD_DEFINITIONS(-DHAVE_YASSL)