summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2020-05-05 20:33:10 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2020-05-05 20:33:10 +0300
commit2c3c851d2cba73825f81cd06220138b15c17ae4d (patch)
tree4130cf52868c41beb3c242ad229031cca73d7e1c /CMakeLists.txt
parent474290540a829edcc6a74be8c354053f330bf5de (diff)
parent8648b9bed86e9f52c027daec760d6ab5ce52e889 (diff)
downloadmariadb-git-2c3c851d2cba73825f81cd06220138b15c17ae4d.tar.gz
Merge 10.3 into 10.4
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 566d6d58d43..50257e5c7cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
# Copyright (c) 2006, 2017, Oracle and/or its affiliates.
-# Copyright (c) 2008, 2019, MariaDB Corporation.
+# Copyright (c) 2008, 2020, MariaDB Corporation.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -245,6 +245,11 @@ INCLUDE(wsrep)
INCLUDE(cpack_rpm)
INCLUDE(cpack_deb)
+OPTION(WITH_DBUG_TRACE "Enable DBUG_ENTER()/DBUG_EXIT()" ON)
+IF(WITH_DBUG_TRACE)
+ ADD_DEFINITIONS(-DDBUG_TRACE)
+ENDIF()
+
# Always enable debug sync for debug builds.
SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DENABLED_DEBUG_SYNC")
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DENABLED_DEBUG_SYNC")