summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-10-21 14:12:23 +0200
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-10-21 14:12:23 +0200
commit00490194630883b5fd08de0bd894c764dfeeffd0 (patch)
treec9d96ee8475623a8f44eb9cf3f73d5c723f470dd /CMakeLists.txt
parent70ac1c71e41585a6fa6eea0ba3d033ec48e2000b (diff)
parent84662b98040ac335af659a7f5a36b887ffe57155 (diff)
downloadmariadb-git-00490194630883b5fd08de0bd894c764dfeeffd0.tar.gz
merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6a95317260..5c349813f68 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,11 @@ IF(WITH_DEBUG)
SET(CMAKE_BUILD_TYPE "Debug" CACHE STRING ${BUILDTYPE_DOCSTRING} FORCE)
SET(MYSQL_MAINTAINER_MODE ON CACHE BOOL
"MySQL maintainer-specific development environment")
+ IF(UNIX AND NOT APPLE)
+ # Compiling with PIC speeds up embedded build, on PIC sensitive systems
+ # Predefine it to ON, in case user chooses to build embedded.
+ SET(WITH_PIC ON CACHE BOOL "Compile with PIC")
+ ENDIF()
SET(OLD_WITH_DEBUG 1 CACHE INTERNAL "" FORCE)
ELSEIF(NOT HAVE_CMAKE_BUILD_TYPE OR OLD_WITH_DEBUG)
IF(CUSTOM_C_FLAGS)