summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-05-02 19:19:46 +0200
committerunknown <df@pippilotta.erinye.com>2007-05-02 19:19:46 +0200
commit4ac4ee4bf13325dc374541da9eeda362be5628d0 (patch)
tree7812a1831bc5e97ecabff998bb1e02161caa57cd /CMakeLists.txt
parent56c184503cdbcbbdca808b178bb0861c055c6d9c (diff)
parent11a630c4ca7099b8599e63b2f7928d8fac69e86b (diff)
downloadmariadb-git-4ac4ee4bf13325dc374541da9eeda362be5628d0.tar.gz
Merge pippilotta.erinye.com:/shared/home/df/mysql/build/mysql-5.0-build-work-cmake-map-files
into pippilotta.erinye.com:/shared/home/df/mysql/build/mysql-5.0-build CMakeLists.txt: Auto merged
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcbd3f4e4bd..288312b37c5 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,6 +116,9 @@ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG
${CMAKE_CXX_FLAGS_DEBUG})
+ # generate map files
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+
# remove support for Exception handling
STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})