summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-10-18 15:38:32 -0200
committerDavi Arnaut <davi.arnaut@oracle.com>2010-10-18 15:38:32 -0200
commitc903377d1eba7e6eb0ec532fe470fe09ad292fc7 (patch)
tree4d0227ce8642b3270ca6cbdb19db2c45f693f993 /CMakeLists.txt
parent4053a5a44832552090218fb7ca685c1c2a2ae006 (diff)
parent5aa81e380cde5bc9f9cd42787286d6db5292d631 (diff)
downloadmariadb-git-c903377d1eba7e6eb0ec532fe470fe09ad292fc7.tar.gz
Merge of mysql-5.1-bugteam into mysql-5.5-bugteam.
CMakeLists.txt: Enable the maintainer mode if debug support is enabled. Does not cause it to be enabled if the user explicitly disabled the maintainer mode.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5eddad4ad15..f6a95317260 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,8 @@ SET(BUILDTYPE_DOCSTRING
IF(WITH_DEBUG)
SET(CMAKE_BUILD_TYPE "Debug" CACHE STRING ${BUILDTYPE_DOCSTRING} FORCE)
+ SET(MYSQL_MAINTAINER_MODE ON CACHE BOOL
+ "MySQL maintainer-specific development environment")
SET(OLD_WITH_DEBUG 1 CACHE INTERNAL "" FORCE)
ELSEIF(NOT HAVE_CMAKE_BUILD_TYPE OR OLD_WITH_DEBUG)
IF(CUSTOM_C_FLAGS)