summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2011-06-17 12:53:41 +0200
committerVladislav Vaintroub <wlad@montyprogram.com>2011-06-17 12:53:41 +0200
commit94b3e6a80912177f3d2b97e189df06f16f381b29 (patch)
tree3b9c7ebfd5a33e9d64fcf57eede98d050197a707 /CMakeLists.txt
parentbf0e1f44c6b3306e84bbfd783c898a1764836242 (diff)
downloadmariadb-git-94b3e6a80912177f3d2b97e189df06f16f381b29.tar.gz
Fiix LPBUG#798629
Define USE_MARIA_FOR_TMP_TABLES preprocessor constant by default if Aria engine is compiled in. Use CMake variable WITH_ARIA_TMP_TABLES to control the temp table engine setting.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c6a65505fe..ea44226781a 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -318,10 +318,12 @@ ENDIF(NOT WITHOUT_PARTITION_STORAGE_ENGINE)
# Special handling for tmp tables with the Aria engine
IF(WITH_ARIA_STORAGE_ENGINE)
ADD_DEFINITIONS(-DWITH_ARIA_STORAGE_ENGINE)
- IF(WITH_MARIA_TMP_TABLES)
+ SET(WITH_ARIA_TMP_TABLES 1 CACHE BOOL "Use Aria for temporary tables")
+ IF(WITH_ARIA_TMP_TABLES)
+ MESSAGE(STATUS "Using Aria for temporary tables")
ADD_DEFINITIONS(-DUSE_MARIA_FOR_TMP_TABLES)
- ENDIF(WITH_MARIA_TMP_TABLES)
-ENDIF(WITH_ARIA_STORAGE_ENGINE)
+ ENDIF()
+ENDIF()
ADD_DEFINITIONS(${STORAGE_ENGINE_DEFS})