summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2014-06-26 12:46:33 +0200
committerSergei Golubchik <serg@mariadb.org>2014-06-26 12:46:33 +0200
commitb7d10e56872f32b437d4d7ef0d1dc1b2ab000d5b (patch)
tree759f169ab1b52cc5936f039312dc8d9a00b23981 /CMakeLists.txt
parentda4f8269bf5919f7a48739dbe5460fe22a768967 (diff)
downloadmariadb-git-b7d10e56872f32b437d4d7ef0d1dc1b2ab000d5b.tar.gz
MDEV-5730 enhance security using special compilation options
add a comment
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc1193c441a..9b5c73b6e6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,6 +199,8 @@ IF (WITH_ASAN)
ENDIF()
ENDIF()
+# enable security hardening features, like most distributions do
+# in our benchmarks that costs about ~1% of performance, depending on the load
OPTION(SECURITY_HARDENED "Use security-enhancing compiler features (stack protector, relro, etc)" ON)
IF(SECURITY_HARDENED)
# security-enhancing flags