summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2022-03-11 09:53:40 +0200
committerMarko Mäkelä <marko.makela@mariadb.com>2022-03-11 09:53:40 +0200
commitbe6f9593feb368cbcb27c191389fe9723ab3045c (patch)
treead13136bff5ad59e4a987f41451b4ceccb2b8a2d /CMakeLists.txt
parentfabaac86a18cfa026ca53b4a62e9edbf0bfd32d4 (diff)
parent5503c4046053a2d0b8c4cd2d331d0bfa25b50e98 (diff)
downloadmariadb-git-be6f9593feb368cbcb27c191389fe9723ab3045c.tar.gz
Merge 10.5 into 10.6
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b9cf961f523..eeee9f7e986 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
# Copyright (c) 2006, 2017, Oracle and/or its affiliates.
-# Copyright (c) 2008, 2021, MariaDB Corporation.
+# Copyright (c) 2008, 2022, MariaDB Corporation.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -80,9 +80,11 @@ SET(MYSQL_PROJECT_NAME_DOCSTRING "MySQL project name")
IF(CMAKE_VERSION VERSION_LESS "3.1")
IF(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
ENDIF()
ELSE()
+ SET(CMAKE_C_STANDARD 99)
SET(CMAKE_CXX_STANDARD 11)
ENDIF()