summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-05-02 19:21:50 +0200
committerunknown <df@pippilotta.erinye.com>2007-05-02 19:21:50 +0200
commiteb92ed037c8819754e5c8e823a311ebda3d5f21f (patch)
treed33afd9fd5e3fe03401ff5d91d1ea65be10f1414 /CMakeLists.txt
parent898fc2e2103204871df969489a3a66bdc84003c8 (diff)
parent4ac4ee4bf13325dc374541da9eeda362be5628d0 (diff)
downloadmariadb-git-eb92ed037c8819754e5c8e823a311ebda3d5f21f.tar.gz
Merge dfischer@bk-internal.mysql.com:/home/bk/mysql-5.0-build
into pippilotta.erinye.com:/shared/home/df/mysql/build/mysql-5.0-build CMakeLists.txt: Auto merged
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68238ea157c..f5a1c0cfaba 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,6 +120,9 @@ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG
${CMAKE_CXX_FLAGS_DEBUG})
+ # generate map files
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+
# remove support for Exception handling
STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})