summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@mariadb.com>2017-09-08 16:08:44 +0000
committerVladislav Vaintroub <wlad@mariadb.com>2017-09-08 18:22:15 +0000
commita46679dcf7b314f365f796fd78e12763a4c2c880 (patch)
treefa7d158cc3eda86b86b1c5183e880f20bf09fcf4 /CMakeLists.txt
parent6be93c3b8a1d8c080d73750e3804752ad80f56d1 (diff)
downloadmariadb-git-a46679dcf7b314f365f796fd78e12763a4c2c880.tar.gz
Build improvements and cleanups.
- the probably ultimate fix for dependencies on VS - remove some GET_TARGET_PROPERTY(LOCATION ...), they are deprecated in cmake 3.9 - simplify signing targets on Windows. - remove INSTALL_DEBUG_TARGET, we do not mix binaries from different builds in the same package
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df4ac556726..11874650d18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -492,6 +492,12 @@ ENDIF()
INCLUDE(CPack)
+IF(WIN32 AND SIGNCODE)
+ # Configure post-install script for authenticode signing
+ CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/sign.cmake.in sign.cmake @ONLY)
+ INSTALL(SCRIPT ${PROJECT_BINARY_DIR}/sign.cmake)
+ENDIF()
+
IF(NON_DISTRIBUTABLE_WARNING)
MESSAGE(WARNING "
You have linked MariaDB with GPLv3 libraries! You may not distribute the resulting binary. If you do, you will put yourself into a legal problem with Free Software Foundation.")