summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2010-11-18 18:02:37 +0200
committerGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2010-11-18 18:02:37 +0200
commit589428b625bdc9667d224d5e2899658519a2bf4b (patch)
tree86087fb2008dec94c59e37c905a29838e172b548 /CMakeLists.txt
parentb295a2510912d40c36fa3a16a99d5f09fc306133 (diff)
downloadmariadb-git-589428b625bdc9667d224d5e2899658519a2bf4b.tar.gz
Bug #50021: Windows standard configuration files are showing Linux
options/settings 1. Changed the default value for socket on Windows to the windows default 2. Removed hard-coded trailing slashes from innodb_data_home_dir and innodb_log_group_name_dir. 3. Added extra backslashes to the innodb directory example 4. Made the tempdir platform "dependent" 5. Fixed the comments in the .ini files 6. Removed the tmpdir from the templates and the scripts
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7da3bd05cef..8276a3506af 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,8 +42,7 @@ ADD_DEFINITIONS(-DSHAREDIR="share")
# Set debug options
SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DFORCE_INIT_OF_VARS")
-
-SET(localstatedir "C:\\mysql\\data")
+SET(localstatedir "C:\\\\mysql\\\\data\\\\")
CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-huge.cnf.sh
${CMAKE_SOURCE_DIR}/support-files/my-huge.ini @ONLY)
CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-innodb-heavy-4G.cnf.sh