summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHe Zhenxing <zhenxing.he@sun.com>2009-10-23 12:56:30 +0800
committerHe Zhenxing <zhenxing.he@sun.com>2009-10-23 12:56:30 +0800
commitb6529a140b55a748a99a22b4b6562faf06cd57a7 (patch)
tree9a5b1366ff418440003a17f8eb21baa18ede113e /CMakeLists.txt
parentf71b836e500d9d0647d492d597f7b49168af32ee (diff)
downloadmariadb-git-b6529a140b55a748a99a22b4b6562faf06cd57a7.tar.gz
Add semi-sync support for Windows
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d91e39eb6d..e7d05f33ffa 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -276,6 +276,10 @@ FOREACH(DIR ${DYNAMIC_ENGINE_DIRECTORIES})
ADD_SUBDIRECTORY(${DIR})
ENDFOREACH(DIR ${DYNAMIC_ENGINE_DIRECTORIES})
+# Add subdirectories for semisync plugin
+IF(NOT WITHOUT_DYNAMIC_PLUGINS)
+ ADD_SUBDIRECTORY(plugin/semisync)
+ENDIF(NOT WITHOUT_DYNAMIC_PLUGINS)
# FIXME "debug" only needed if build type is "Debug", but
# CMAKE_BUILD_TYPE is not set during configure time.