summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <vvaintroub/Wlad@vaio.>2008-01-11 15:45:18 +0100
committerunknown <vvaintroub/Wlad@vaio.>2008-01-11 15:45:18 +0100
commit45500a70f09767cd0d3d973610c1289b60dc94c8 (patch)
tree5097719cb90f7f8d37f6dc504d6085a83afef342 /CMakeLists.txt
parent266fde77b283237fa2dd6db0f97fb68289fe0c21 (diff)
downloadmariadb-git-45500a70f09767cd0d3d973610c1289b60dc94c8.tar.gz
Fix windows warnings using correct datatypes if possible
and casts if not. Add optional WITH_MARIA_TMP_TABLES parameter to configure.js. This parameter defaults to true, if WITH_MARIA_STORAGE_ENGINE is present. CMakeLists.txt: Add WITH_MARIA_TMP_TABLES config parameter. storage/maria/ma_blockrec.c: Fix windows warning - use the correct datatype. storage/maria/ma_loghandler.c: Fix windows warnings by adding casts. storage/maria/ma_pagecache.c: Fix windows warning - use the correct datatype. storage/maria/ma_recovery.c: Fix windows warning by adding casts. win/configure.js: Add WITH_MARIA_TMP_TABLES. If WITH_MARIA_STORAGE_ENGINE is present, it defaults to TRUE. To unset, pass WITH_MARIA_TMP_TABLES=FALSE to configure.js
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4ec57a53cf..4e82ecdd615 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,6 +77,9 @@ IF(WITH_FEDERATED_STORAGE_ENGINE)
ENDIF(WITH_FEDERATED_STORAGE_ENGINE)
IF(WITH_MARIA_STORAGE_ENGINE)
ADD_DEFINITIONS(-DWITH_MARIA_STORAGE_ENGINE)
+ IF(WITH_MARIA_TMP_TABLES)
+ ADD_DEFINITIONS(-DUSE_MARIA_FOR_TMP_TABLES)
+ ENDIF(WITH_MARIA_TMP_TABLES)
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_maria_plugin")
ENDIF(WITH_MARIA_STORAGE_ENGINE)