summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Perkin <jperkin@sun.com>2009-08-14 17:18:52 +0200
committerJonathan Perkin <jperkin@sun.com>2009-08-14 17:18:52 +0200
commita162954858bbffe7f3d11a780183b0ec2606e93a (patch)
tree357bfb250262e00ce901f945f167016febe406d1 /CMakeLists.txt
parent00eec234ee79ae9859a98fe906e78cb3af4e89cc (diff)
downloadmariadb-git-a162954858bbffe7f3d11a780183b0ec2606e93a.tar.gz
Build fixes for Windows, AIX, HP/UX and Sun Studio11, from Timothy Smith.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 947dc1786ff..7d91e39eb6d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,6 +137,7 @@ ENDIF(MSVC)
IF(WIN32)
ADD_DEFINITIONS("-D_WINDOWS -D__WIN__ -D_CRT_SECURE_NO_DEPRECATE")
+ ADD_DEFINITIONS("-D_WIN32_WINNT=0x0501")
ENDIF(WIN32)
# default to x86 platform. We'll check for X64 in a bit