summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2011-11-26 23:07:53 +0100
committerVladislav Vaintroub <wlad@montyprogram.com>2011-11-26 23:07:53 +0100
commit64e308e28d2b0fb4cd005e23189e3639912bcd60 (patch)
tree07aa8c5d623328ff0288dba79634ec3e2a9ed5e3 /CMakeLists.txt
parent6be24a771a27a077d58d21a4a1f8db3fbd14cac4 (diff)
downloadmariadb-git-64e308e28d2b0fb4cd005e23189e3639912bcd60.tar.gz
Fix build and packaging on Windows:
- build executables we have in 5.3 (mysql_install_db.exe, mysq_upgrade_service.exe, upgrade wizard), and MSI - add some missing headers to windows specific source files. This needs to be done since 5.5 is using WIN32_LEAN_AND_MEAN preprocessor constant thus windows.h no more includes whiole Windows - do not deliver perl scripts (mysql_install_db.pl & friends) -they do not work, are not documented, and we have native executables for this functionality. do not pack echo.exe, replace.exe into MSI, they are not needed. Do not build resolveip on Windows, it is not used. - precache results of of system checks in cmake/os/WindowsCache.cmake (like it is alreay done for majority of tests to speed up cmake run with VS) - make feedback plugin DEFAULT on Windows (so MSI works if user enables plugin), fix null pointer access in PSI_register
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83145c72f43..d6cfd7fc288 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -318,6 +318,11 @@ ENDIF()
INCLUDE(cmake/abi_check.cmake)
INCLUDE(cmake/tags.cmake)
+IF(WIN32)
+ ADD_SUBDIRECTORY(win/packaging)
+ ADD_SUBDIRECTORY(win/upgrade_wizard)
+ENDIF()
+
CONFIGURE_FILE(config.h.cmake ${CMAKE_BINARY_DIR}/include/my_config.h)
CONFIGURE_FILE(config.h.cmake ${CMAKE_BINARY_DIR}/include/config.h)
CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/include/mysql_version.h.in
@@ -349,7 +354,7 @@ IF(WIN32)
ELSE()
SET(CPACK_GENERATOR "TGZ")
ENDIF()
-ADD_SUBDIRECTORY(packaging/WiX)
+
# Create a single package with "make package"
# (see http://public.kitware.com/Bug/view.php?id=11452)