summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Vojtovich <svoj@mariadb.org>2016-07-05 16:37:42 +0400
committerSergey Vojtovich <svoj@mariadb.org>2016-08-04 10:45:20 +0400
commit9c2215e022c325599bd1b66d1f2214529fb99a24 (patch)
tree03aff125ec9f83a01c813badc4988f821416c724 /CMakeLists.txt
parent86975e0492c03535271aea67e0b5e7e8fd0b1b78 (diff)
downloadmariadb-git-9c2215e022c325599bd1b66d1f2214529fb99a24.tar.gz
MDEV-9872 - Add common optimized CRC32 function interface
Move crc32-vpmsum to extra. Compile static crc32-vpmsum instead of adding sources directly. Make use of crc32-vpmsum via my_checksum(). Based on contribution by Daniel Black.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f8ae5b2d9c..3ace4084acd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,6 +153,7 @@ INCLUDE(plugin)
INCLUDE(install_macros)
INCLUDE(systemd)
INCLUDE(mysql_add_executable)
+INCLUDE(crc32-vpmsum)
# Handle options
OPTION(DISABLE_SHARED