summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordf@pippilotta.erinye.com <>2007-07-19 23:06:34 +0200
committerdf@pippilotta.erinye.com <>2007-07-19 23:06:34 +0200
commitcccecb833bc361cb0b1907503025d76be260f10c (patch)
tree5d33aa92ae3706ae94d0da9d934f712abee800aa /CMakeLists.txt
parent4bab858fba5e6679fe8ec4209aa6b59be87fd824 (diff)
downloadmariadb-git-cccecb833bc361cb0b1907503025d76be260f10c.tar.gz
BUG#20815 Errno 12 on Windows after 197 connections
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2a828c1843..cdd0cde8b8d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,6 +123,9 @@ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
# generate map files
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+ # set stack size (see bug#20815)
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /STACK:1048576")
+
# remove support for Exception handling
STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})