summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Barkov <bar@mariadb.org>2013-04-25 17:12:52 +0400
committerAlexander Barkov <bar@mariadb.org>2013-04-25 17:12:52 +0400
commitbc80fb07ded7abcfb99d368d14e4c5e81a669101 (patch)
tree4ad02b3ecbc9d357c7d6a18c55e97103da1d0eb4 /CMakeLists.txt
parent616e7a7466d2a9bceec9b2c968ce5cbf8035eba4 (diff)
downloadmariadb-git-bc80fb07ded7abcfb99d368d14e4c5e81a669101.tar.gz
ha_cassandra.so and ha_oqgraph.so can be build only if boost is installed
on the build machine. So put them into the deb packages optionally. Additionally, fixing cassandra/CMakeLists.txt to work with thrift installed in /opt/local and /opt. It was supposed to work, but did not work actually. Only thrift installed in /usr or /usr/local worked. renamed: debian/dist/Debian/mariadb-server-10.0.files => debian/dist/Debian/mariadb-server-10.0.files.in debian/dist/Ubuntu/mariadb-server-10.0.files => debian/dist/Ubuntu/mariadb-server-10.0.files.in modified: .bzrignore CMakeLists.txt storage/cassandra/CMakeLists.txt storage/cassandra/cassandra_se.cc storage/cassandra/gen-cpp/Cassandra.h storage/cassandra/gen-cpp/cassandra_types.h storage/oqgraph/CMakeLists.txt debian/dist/Debian/mariadb-server-10.0.files.in debian/dist/Ubuntu/mariadb-server-10.0.files.in
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 823bac6b6e3..19f951c7589 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -345,6 +345,18 @@ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/sql/sql_builtin.cc.in
CONFIGURE_FILE(
${CMAKE_SOURCE_DIR}/cmake/info_macros.cmake.in ${CMAKE_BINARY_DIR}/info_macros.cmake @ONLY)
+IF(DEB)
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/debian/mariadb-server-10.0.files.in
+ ${CMAKE_SOURCE_DIR}/debian/mariadb-server-10.0.files)
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/debian/dist/Debian/mariadb-server-10.0.files.in
+ ${CMAKE_SOURCE_DIR}/debian/dist/Debian/mariadb-server-10.0.files)
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/debian/dist/Ubuntu/mariadb-server-10.0.files.in
+ ${CMAKE_SOURCE_DIR}/debian/dist/Ubuntu/mariadb-server-10.0.files)
+ENDIF(DEB)
+
# Handle the "INFO_*" files.
INCLUDE(${CMAKE_BINARY_DIR}/info_macros.cmake)
# Source: This can be done during the cmake phase, all information is