summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorgi Kodinov <joro@sun.com>2009-07-15 16:46:25 +0300
committerGeorgi Kodinov <joro@sun.com>2009-07-15 16:46:25 +0300
commit8acf778eaedf32ccfa73eb1b80b7eca17071b270 (patch)
treeea0b301e5ab03dbeb0d739fbb172d2221329c2db /CMakeLists.txt
parentaa737dfc22e2db9741bd46197c002708dbd7d0fa (diff)
downloadmariadb-git-8acf778eaedf32ccfa73eb1b80b7eca17071b270.tar.gz
Bug #45287: phase 1 : 32 bit compilation warnings
Fixed the following problems: 1. cmake 2.6 warning because of a changed default on how the dependencies to libraries with a specified path are resolved. Fixed by requiring cmake 2.6. 2. Removed an obsolete pre-NT4 hack including defining Windows system defines to alter the behavior of windows.h. 3. Disabled warning C4065 on compiling sql_yacc.cc because of a know incompatibility in some of the newer bison binaries.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91c3a804eea..9f53a9fb146 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-CMAKE_MINIMUM_REQUIRED(VERSION 2.4.7 FATAL_ERROR)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6 FATAL_ERROR)
PROJECT(MySql)