summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <knielsen@knielsen-hq.org>2009-06-09 14:21:26 +0200
committerunknown <knielsen@knielsen-hq.org>2009-06-09 14:21:26 +0200
commit8be051d7031f8787920f48827e35535151486d98 (patch)
treecfb0990130f8a0122e91fd847221d04716176f74 /CMakeLists.txt
parenta6b7f71329ceb7d0188572f494b5d1a1f0461fc5 (diff)
downloadmariadb-git-8be051d7031f8787920f48827e35535151486d98.tar.gz
XtraDB after-merge fix: Fix building from storage/xtradb/ instead of storage/innodb/
.bzrignore: XtraDB compiles innodb in storage/xtradb instead of storage/innobase CMakeLists.txt: Take InnoDB code from storage/xtradb/ instead of storage/innobase/ libmysqld/CMakeLists.txt: Take InnoDB code from storage/xtradb/ instead of storage/innobase/ storage/innobase/plug.in.disabled: Disable building old InnoDB from storage/innobase/ directory. We will keep the files around to avoid getting merge conflicts for every MySQL upstream change to InnoDB. storage/xtradb/CMakeLists.txt: Take InnoDB code from storage/xtradb/ instead of storage/innobase/ storage/xtradb/COPYING: Remove not needed file from XtraDB. storage/xtradb/Makefile.am: Take InnoDB code from storage/xtradb/ instead of storage/innobase/ storage/xtradb/Makefile.in: Remove not needed file from XtraDB. storage/xtradb/handler/ha_innodb.cc: Take InnoDB code from storage/xtradb/ instead of storage/innobase/ storage/xtradb/plug.in: Take InnoDB code from storage/xtradb/ instead of storage/innobase/ storage/xtradb/row/row0ins.c: Take InnoDB code from storage/xtradb/ instead of storage/innobase/
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 89b6a9c5d3f..ff22e9774af 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -257,7 +257,7 @@ IF(WITH_FEDERATED_STORAGE_ENGINE)
ADD_SUBDIRECTORY(storage/federated)
ENDIF(WITH_FEDERATED_STORAGE_ENGINE)
IF(WITH_INNOBASE_STORAGE_ENGINE)
- ADD_SUBDIRECTORY(storage/innobase)
+ ADD_SUBDIRECTORY(storage/xtradb)
ENDIF(WITH_INNOBASE_STORAGE_ENGINE)
IF(WITH_MARIA_STORAGE_ENGINE)
ADD_SUBDIRECTORY(storage/maria)